Friday 23 June 2017

UVA 490 - Rotating Sentences

Problem : Rotating Sentences
In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left. 

Input and Output
As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.) 
The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column. 

Sample Input
Rene Decartes once said,
"I think, therefore I am."

Sample Output
"R
Ie
 n
te

iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"

My accepted code is given below:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    char s[1009][109];
    long long i,l,c,ll,mx,j;
    //while(true)

    c=0;
    mx=-1;
    while(gets(s[c]))
    {
        ll=strlen(s[c]);
        if(mx<ll)
            mx=ll;
        c++;

    }
    //cout<<"mx="<<mx<<endl;
    for(i=0; i<mx; i++)
    {

        for(j=c-1; j>=0; j--)
        {
            l=strlen(s[j]);
            if(i<l)
                cout<<s[j][i];
            else
                cout<<" ";
        }
        cout<<endl;
    }

    return 0;
}

No comments:

Post a Comment