Thursday 9 February 2017

uva 10812 - Beat the Spread!

Problem:uva 10812 - Beat the Spread!
Superbowl Sunday is nearly here. In order to pass the time waiting
for the half-time commercials and wardrobe malfunctions, the local
hackers have organized a betting pool on the game. Members place
their bets on the sum of the two nal scores, or on the absolute
difference between the two scores.
Given the winning numbers for each type of bet, can you deduce
the nal scores?
Input
The rst line of input contains n, the number of test cases. n lines
follow, each representing a test case. Each test case gives s and d,
non-negative integers representing the sum and (absolute) difference between the two nal scores.
Output
For each test case, output a line giving the two nal scores, largest rst. If there are no such scores,
output a line containing \impossible". Recall that football scores are always non-negative integers.
Sample Input
2
40 20
20 40
Sample Output
30 10
impossible
Code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
    long long a,b,t,aa,bb;
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        aa=(a+b)/2;
        bb=(a-b)/2;
        if((a+b)%2!=0||a<b)
            cout<<"impossible"<<endl;
        else
            cout<<aa<<" "<<bb<<endl;
           // else

    }
    return 0;
}

Friday 3 February 2017

uva 113 - Power of Cryptography

Problem: https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=24&problem=49&mosmsg=Submission+received+with+ID+18722967
Code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
    double a,b;
    while(cin>>a>>b)
    {
        //cout<<b<<a<<endl;
        //cout<<<<endl;

        printf("%.0lf\n",pow(b,1/a));
    }
    return 0;
}

UVA 11461 - Square Numbers

Problem: https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=24&problem=2456&mosmsg=Submission+received+with+ID+18720652

Code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
    long long a,b,c,aa,bb;
    long long i;
    while(cin>>a>>b)
    {
        aa=sqrt(a);
        bb=sqrt(b);
        if(a==0&&b==0)
            break;
            if(aa*aa==a)
                aa--;

        cout<<bb-aa<<endl;
    }
    return 0;

}