Sunday 9 July 2017

UVA 572 - Oil Deposits

Solution of the  UVA 572 - Oil Deposits:
problem:
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits.
GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides
the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to
determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the
same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number
of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 m 100 and 1 n 100. Following this are m lines of n characters each (not counting
the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the
absence of oil, or ‘@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same
oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.
Sample Input
1 1
*3
5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output

0
1
2
2
My accepted code is given below:

#include<bits/stdc++.h>
using namespace std;
//map <int,vector <int > >graph;
char ar[109][109];
long long n,m;
#define pii pair<long long,long long>
long long a[]= {0,0,1,-1,1,-1,-1,1};
long long b[]= {1,-1,0,0,1,1,-1,-1};
int bsf(long long ii,long long jj)
{
    long long i,j,x,y;
    queue<pii> q;
    q.push(pii(ii,jj));
    while(!q.empty())
    {
        pii top=q.front();
        q.pop();
        for(i=0; i<8; i++)
        {


            x=top.first+a[i];
            y=top.second+b[i];
            if(x>=0&&x<n&&y>=0&&y<m&&ar[x][y]=='@')
            {

                    q.push(pii(x,y));
                    ar[x][y]='*';

            }

        }
    }
}
int main()
{
    long long i,j;
    while(cin>>n>>m)
    {
        if(n==0)
            break;
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                cin>>ar[i][j];
                //visit[i][j]=0;

            }
        }
        long long count=0;
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                if(ar[i][j]=='@')
                {
                    bsf(i,j);
                    count++;
                }

            }
        }
        cout<<count<<endl;
        //cout<<"kjh"<<endl;
    }
    return 0;
}

No comments:

Post a Comment