Problem:uva 10812 - Beat the Spread!
Superbowl Sunday is nearly here. In order to pass the time waiting
for the half-time commercials and wardrobe malfunctions, the local
hackers have organized a betting pool on the game. Members place
their bets on the sum of the two nal scores, or on the absolute
difference between the two scores.
Given the winning numbers for each type of bet, can you deduce
the nal scores?
Input
The rst line of input contains n, the number of test cases. n lines
follow, each representing a test case. Each test case gives s and d,
non-negative integers representing the sum and (absolute) difference between the two nal scores.
Output
For each test case, output a line giving the two nal scores, largest rst. If there are no such scores,
output a line containing \impossible". Recall that football scores are always non-negative integers.
Sample Input
2
40 20
20 40
Sample Output
30 10
impossible
Code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
long long a,b,t,aa,bb;
cin>>t;
while(t--)
{
cin>>a>>b;
aa=(a+b)/2;
bb=(a-b)/2;
if((a+b)%2!=0||a<b)
cout<<"impossible"<<endl;
else
cout<<aa<<" "<<bb<<endl;
// else
}
return 0;
}
Superbowl Sunday is nearly here. In order to pass the time waiting
for the half-time commercials and wardrobe malfunctions, the local
hackers have organized a betting pool on the game. Members place
their bets on the sum of the two nal scores, or on the absolute
difference between the two scores.
Given the winning numbers for each type of bet, can you deduce
the nal scores?
Input
The rst line of input contains n, the number of test cases. n lines
follow, each representing a test case. Each test case gives s and d,
non-negative integers representing the sum and (absolute) difference between the two nal scores.
Output
For each test case, output a line giving the two nal scores, largest rst. If there are no such scores,
output a line containing \impossible". Recall that football scores are always non-negative integers.
Sample Input
2
40 20
20 40
Sample Output
30 10
impossible
Code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
long long a,b,t,aa,bb;
cin>>t;
while(t--)
{
cin>>a>>b;
aa=(a+b)/2;
bb=(a-b)/2;
if((a+b)%2!=0||a<b)
cout<<"impossible"<<endl;
else
cout<<aa<<" "<<bb<<endl;
// else
}
return 0;
}